dotfiles/machines/sashimi/brew.nix
winston ab0d3a9974
All checks were successful
/ check (push) Successful in 5m2s
chore: update for macOS Sequoia
2024-09-18 14:54:01 +02:00

53 lines
969 B
Nix

{ config, ... }:
let
noQuarantine = name: {
inherit name;
args.no_quarantine = true;
};
skipSha = name: {
inherit name;
args.require_sha = false;
};
in
{
# make brew available in PATH
environment.systemPath = [ config.homebrew.brewPrefix ];
homebrew = {
enable = true;
caskArgs.require_sha = true;
brews = [ ];
casks = [
"1password"
"affinity-designer"
"affinity-photo"
"affinity-publisher"
"alfred"
"blender"
"element"
"elgato-wave-link"
"eloston-chromium"
"iina"
"imageoptim"
"jetbrains-toolbox"
"keka"
"little-snitch"
"macfuse"
"mullvad-browser"
"mullvadvpn"
"orbstack"
"orion"
"rustdesk"
"signal"
(skipSha "sizzy")
"uhk-agent"
"uninstallpkg"
"utm"
"yubico-yubikey-manager"
];
onActivation = {
autoUpdate = true;
upgrade = true;
};
};
}